WILDERNIX
Яндекс.Метрика
 | Список статей | Сертификаты | Резюме(CV) | Правила | Вход |

 
Категории:
Ubuntu (9)
CISCO (10)
FreeBSD (7)
SQUID (1)
Windows Server (8)
PHP (3)
1C (8)
MS SQL (7)
MySQL (7)
Yii Framework (3)
Java (1)
Network (1)
PowerShell (7)
Git (1)
Python (1)

 
Микроблоги:
ОАЭ - Дубай
Фото зарисовки

 
Друзья:
arturka.com
aleksandor.ru
burunduch.ru
rapball.ru
pbshar.ru


Flag Counter

      GitHub profile


Как программно заполнить и вывести макет (1C)
Предположим в обработке есть макет - МакетЗаказ, пример ниже демонстрирует как заполнить области макета и вывести его на просмотр пользователю



// Переменная для построения отчета
ТабДок = новый ТабличныйДокумент;

// Получим макет ПР
МакетЗак = ЭтотОбъект.ПолучитьМакет("МакетЗаказ");

// Получим область Шапка
ОбластьШапка = МакетЗак.ПолучитьОбласть("Шапка");
ОбластьШапка.Параметры.Дата = Формат(ТекущаяДата(), "ДФ=dd.MM.yyyy");
ТабДок.Вывести(ОбластьШапка);

// Заголовок таблицы
ОбластьЗаголовокТаблицы = МакетЗак.ПолучитьОбласть("ЗаголовокТаблицы");
ТабДок.Вывести(ОбластьЗаголовокТаблицы);


// Заполним таблицу картриджами в переменную - СписокКартриджей
// ПолучитьСписокКартриджей(Истина) - возвращает список картриджей
Если Флажок_Показывать_с_нулевым_минимумом = Истина Тогда
СписокКартриджей = ПолучитьСписокКартриджей(Истина);
Иначе
СписокКартриджей = ПолучитьСписокКартриджей(Ложь);
КонецЕсли;

ОбластьСтрокаПозицииЗаказа = МакетЗак.ПолучитьОбласть("СтрокаПозицииЗаказа");

Счетчик = 1;

Для каждого Картридж из СписокКартриджей Цикл


Если (Картридж.КолВоКЗаказу <> Неопределено) и (Картридж.КолВоКЗаказу > 0) Тогда
ОбластьСтрокаПозицииЗаказа.Параметры.НомерПозиции = Счетчик;

ОбластьСтрокаПозицииЗаказа.Параметры.Артикул = Справочники.Номенклатура.НайтиПоНаименованию(Картридж.Наименование).Артикул;
ОбластьСтрокаПозицииЗаказа.Параметры.Наименование = Справочники.Номенклатура.НайтиПоНаименованию(Картридж.Наименование).Наименование;
ОбластьСтрокаПозицииЗаказа.Параметры.КолВо = Картридж.КолВоКЗаказу;
ОбластьСтрокаПозицииЗаказа.Параметры.ЕдИзм = Справочники.Номенклатура.НайтиПоНаименованию(Картридж.Наименование).ЕдиницаХраненияОстатков.Наименование;
ТабДок.Вывести(ОбластьСтрокаПозицииЗаказа);

Счетчик = Счетчик + 1;

КонецЕсли;
КонецЦикла;

// Подвал таблицы
ОбластьПодвалТаблицы = МакетЗак.ПолучитьОбласть("ПодвалТаблицы");
ОбластьПодвалТаблицы.Параметры.Комментарий = "Плановый заказ картриджей";
ТабДок.Вывести(ОбластьПодвалТаблицы);

// Подвал
ОбластьПодвал = МакетЗак.ПолучитьОбласть("Подвал");
ТабДок.Вывести(ОбластьПодвал);

ТабДок.Показать();

Дата публикации: 19-03-2019


WilderNix - Konstantin Korsunov