WILDERNIX
Яндекс.Метрика
 | Список статей | Сертификаты | Резюме(CV) | Правила | Вход |

 
Категории:
Ubuntu (9)
CISCO (10)
FreeBSD (7)
SQUID (1)
Windows Server (8)
PHP (3)
1C (8)
MS SQL (7)
MySQL (7)
Yii Framework (3)
Java (1)
Network (1)
PowerShell (7)
Git (1)
Python (1)

 
Микроблоги:
ОАЭ - Дубай
Фото зарисовки

 
Друзья:
arturka.com
aleksandor.ru
burunduch.ru
rapball.ru
pbshar.ru


Flag Counter

      GitHub profile


Как программно создать и заполненить документ (1C)
Пример программного создания и заполнения документа "Внутренний заказ"
Заполнение документа выполняется через данные формы, точнее реквизиты.

Список коллекции списка картриджей формируется функцией ПолучитьСписокКартриджей(Истина), которая возвращает табличное поле,
где параметр:
Истина - вернет список картриджей, где мимимально необходимый остаток не 0
Ложь - вернет список всех картриджей


// Создать документ заказа
ФормаДокумента = ПолучитьФорму("Документ.ВнутреннийЗаказ.ФормаОбъекта",,ЭтаФорма);

ФормаДокумента.Организация = Справочники.Организации.НайтиПоНаименованию("Компания").Ссылка;
ФормаДокумента.Заказчик = Справочники.Подразделения.НайтиПоНаименованию("ИТ отдел").Ссылка;
ФормаДокумента.Комментарий = "Тонер для принтера";


Если Флажок_Показывать_с_нулевым_минимумом = Истина Тогда
СписокКартриджей = ПолучитьСписокКартриджей(Истина); // функция получает список картриджей с остатками
Иначе
СписокКартриджей = ПолучитьСписокКартриджей(Ложь);
КонецЕсли;

Для Каждого Картридж из СписокКартриджей Цикл

Если (Картридж.КолВоВЗаказ <> Неопределено) и (Картридж.КолВоВЗаказ > 0) Тогда

НовыйТовар = ФормаДокумента.Товары.Добавить();
НовыйТовар.Номенклатура = Справочники.Номенклатура.НайтиПоНаименованию(Картридж.Модель).Ссылка;
НовыйТовар.Количество = Картридж.КолВоВЗаказ;
НовыйТовар.ЕдиницаИзмерения = Справочники.Номенклатура.НайтиПоНаименованию(Картридж.Модель).ЕдиницаХраненияОстатков.Ссылка;
НовыйТовар.Коэффициент = 1;

КонецЕсли;

КонецЦикла;

ФормаДокумента.Открыть();

Дата публикации: 16-03-2019


WilderNix - Konstantin Korsunov