WILDERNIX
Яндекс.Метрика
 | Список статей | Сертификаты | Резюме(CV) | Правила | Вход |

 
Категории:
Ubuntu (9)
CISCO (10)
FreeBSD (7)
SQUID (1)
Windows Server (8)
PHP (3)
1C (8)
MS SQL (7)
MySQL (7)
Yii Framework (3)
Java (1)
Network (1)
PowerShell (7)
Git (1)
Python (1)

 
Микроблоги:
ОАЭ - Дубай
Фото зарисовки

 
Друзья:
arturka.com
aleksandor.ru
burunduch.ru
rapball.ru
pbshar.ru


Flag Counter

      GitHub profile


Обработка для редактирования чеков (Розница 1.0) (1C)
Обработка для выполнения основных операций с чеками:
- Смена статуса.
- Указание смены.
- Указание документа продажи.

Если вам часто приходится корректировать чеки, эта обработка поможет более оперативно искать необходимые чеки, менять статус и выполнять корректировки.

> Ссылка <
Подробнее   
Дата публикации: 19-03-2019   

Как программно заполнить и вывести макет (1C)
Предположим в обработке есть макет - МакетЗаказ, пример ниже демонстрирует как заполнить области макета и вывести его на просмотр пользователю

Подробнее   
Дата публикации: 19-03-2019   

Как программно создать и заполненить документ (1C)
Пример программного создания и заполнения документа "Внутренний заказ"
Заполнение документа выполняется через данные формы, точнее реквизиты.

Список коллекции списка картриджей формируется функцией ПолучитьСписокКартриджей(Истина), которая возвращает табличное поле,
где параметр:
Истина - вернет список картриджей, где мимимально необходимый остаток не 0
Ложь - вернет список всех картриджей

Подробнее   
Дата публикации: 16-03-2019   

1C 8.3 "Не включена возможность загрузки адресного классификатора в настройках" (1C)
1.Открываем секцию "Администрирование".
2.Затем "Поддержка и обслуживание".
3.В секции "Настройка обращения к сервисам" выбрать "Заполнить данные для обращения к сервисам".
4.Заполнить поле "Организация", "Регистрационный номер конфигурации", "Регистрационный номер основной поставки",
Далее выбрать классификаторы, которые необходимо загружать.
5.Выбрать "Записать и закрыть".
Подробнее   
Дата публикации: 14-08-2016   

1С 7.7 Запрос остатков ТМЦ (ТиС). (1C)
Понадобилось выбрать остатки товара и сгруппировать по размерам:

Процедура ЗапросОстатков(КодТовара)

Запрос = СоздатьОбъект("Запрос");

ТекстЗапроса = "Обрабатывать НеПомеченныеНаУдаление;
|Номенклатура = Регистр.ОстаткиТМЦ.Номенклатура;
|Размер = Регистр.ОстаткиТМЦ.Размер;
|Количество = Регистр.ОстаткиТМЦ.Количество;
|Код = Регистр.ОстаткиТМЦ.Номенклатура.Код;
|Функция КоличествоКонОст = КонОст(Количество);
|Группировка Размер;
|Условие(Код ="""+КодТовара+""");";

Если Запрос.Выполнить(ТекстЗапроса) = 1 Тогда
Запрос.Выгрузить(СписокДоступныхРазмеров,0,0);
КонецЕсли;

// где СписокДоступныхРазмеров - таблица значений на форме.

КонецПроцедуры
Подробнее   
Дата публикации: 28-07-2016   

Дата документа не соответствует текущей дате (1C)
Дата документа не соответствует текущей дате или дате последнего оперативно проведенного документа

Причины:

1.Оперативная отметка времени сдвинута на дату большую чем текущая. необходимо
проверить отметку времени можно в "Сервис - Параметры"

2.Если используется клиент-серверная версия, и на клиенте все в порядке с датой,
тогда нужно проверить дату на сервере.
Подробнее   
Дата публикации: 08-09-2015   

Как установить границу последовательности в УТ. (1C)
Как установить границу последовательности в УТ.

Иногда возникает потребность установить границу
последовательности на определенную дату.

Это команда может помочь:

Последовательности.ПартионныйУчет.УстановитьГраницу(Дата(2015,07,20));

Выполнить можно например в «Консоли Кода»
Подробнее   
Дата публикации: 07-09-2015   

Функция подключения к БД через COM (1C)
Пример простой функции для подключения к информационной базе через COM

Функция возвращает объект ИБ, в котором уже можно создавать запросы.

Функция ПодключитьИБ(ИмяСервера, ПортСервера, ИмяИБ, ИмяПользователя, ПарольПользователя) Экспорт

ПараметрыСоединения = "Srvr="""+ИмяСервера+":"+ПортСервера+""";Ref="""+ИмяИБ+""";Usr="""+ИмяПользователя+""";Pwd="""+ПарольПользователя+""";";
V8_COM_Коннектор = Новый COMОбъект("v82.ComConnector");
ОбъектИБ = V8_COM_Коннектор.connect(ПараметрыСоединения);

Возврат ОбъектИБ; // Возвращаем объект ИБ

КонецФункции
Подробнее   
Дата публикации: 23-07-2015   

Страницы: